import re
regex = re.compile(r"(?:(?:###)?([^# \n]+))(?=$|(?:###[^# ]+)*[^\n]*?(http:\/\/[^\n]+))(?: http:\/\/[^\n]+)?")
test_str = ("a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn http://www.zjmainstay.cn/my-regexp\n"
"a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn###a4@zjmainstay.cn###a5@zjmainstay.cn http://www.zjmainstay.cn/deep-regexp")
subst = "$1 $2\\n"
result = regex.sub(subst, test_str)
if result:
print(result)