import Foundation
let pattern = ####"(?:(?:###)?([^# \n]+))(?=$|(?:###[^# ]+)*[^\n]*?(http:\/\/[^\n]+))(?: http:\/\/[^\n]+)?"####
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ####"""
a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn http://www.zjmainstay.cn/my-regexp
a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn###a4@zjmainstay.cn###a5@zjmainstay.cn http://www.zjmainstay.cn/deep-regexp
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)