use strict;
my $str = 'a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn http://www.zjmainstay.cn/my-regexp
a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn###a4@zjmainstay.cn###a5@zjmainstay.cn http://www.zjmainstay.cn/deep-regexp';
my $regex = qr/(?:(?:###)?([^# \n]+))(?=$|(?:###[^# ]+)*[^\n]*?(http:\/\/[^\n]+))(?: http:\/\/[^\n]+)?/p;
my $subst = '$1 $2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";