using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![""'>])(http|ftp)(s)?://((?:[-\w]+\.)+\S+[^,.\s])";
string substitution = @"<a href=""$1$2://$3"">$3</a>";
string input = @"http://www.example.com
https://www.example.com
www.example.com
<a href=""http://www.example.com"">http://www.example.com</a>
<a href=""mailto:email@gmail.com"">email@gmail.com</a>
http://txttag.mee
<i src=""http://www.google.com"">hi</i>
<a href=""http://google.com""></a>
https://www.txttag.mee
ftp://www.example.com
ftps://www.example.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}