re = /(?<!["'>])(http|ftp)(s)?:\/\/((?:[-\w]+\.)+\S+[^,.\s])/
str = 'http://www.example.com
https://www.example.com
www.example.com
<a href="http://www.example.com">http://www.example.com</a>
<a href="mailto:email@gmail.com">email@gmail.com</a>
http://txttag.mee
<i src="http://www.google.com">hi</i>
<a href="http://google.com"></a>
https://www.txttag.mee
ftp://www.example.com
ftps://www.example.com'
subst = '<a href="$1$2://$3">$3</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result