const regex = new RegExp('(?<!["\\'>])(http|ftp)(s)?://((?:[-\\w]+\\.)+\\S+[^,.\\s])', 'g')
const str = `http://www.example.com
https://www.example.com
www.example.com
<a href="http://www.example.com">http://www.example.com</a>
<a href="mailto:email@gmail.com">email@gmail.com</a>
http://txttag.mee
<i src="http://www.google.com">hi</i>
<a href="http://google.com"></a>
https://www.txttag.mee
ftp://www.example.com
ftps://www.example.com`;
const subst = `<a href="$1$2://$3">$3</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);