import re
regex = re.compile(r"(?<![\"'>])(http|ftp)(s)?://((?:[-\w]+\.)+\S+[^,.\s])")
test_str = ("http://www.example.com\n"
"https://www.example.com\n"
"www.example.com\n"
"<a href=\"http://www.example.com\">http://www.example.com</a>\n"
"<a href=\"mailto:email@gmail.com\">email@gmail.com</a>\n"
"http://txttag.mee\n"
"<i src=\"http://www.google.com\">hi</i>\n"
"<a href=\"http://google.com\"></a>\n"
"https://www.txttag.mee\n"
"ftp://www.example.com\n"
"ftps://www.example.com")
subst = "<a href=\"$1$2://$3\">$3</a>"
result = regex.sub(subst, test_str)
if result:
print(result)