use strict;
my $str = 'http://www.example.com
https://www.example.com
www.example.com
<a href="http://www.example.com">http://www.example.com</a>
<a href="mailto:email@gmail.com">email@gmail.com</a>
http://txttag.mee
<i src="http://www.google.com">hi</i>
<a href="http://google.com"></a>
https://www.txttag.mee
ftp://www.example.com
ftps://www.example.com';
my $regex = qr~(?<!["'>])(http|ftp)(s)?://((?:[-\w]+\.)+\S+[^,.\s])~p;
my $subst = '<a href="$1$2://$3">$3</a>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";