import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\"'>])(http|ftp)(s)?://((?:[-\\w]+\\.)+\\S+[^,.\\s])";
final String string = "http://www.example.com\n"
+ "https://www.example.com\n"
+ "www.example.com\n"
+ "<a href=\"http://www.example.com\">http://www.example.com</a>\n"
+ "<a href=\"mailto:email@gmail.com\">email@gmail.com</a>\n"
+ "http://txttag.mee\n"
+ "<i src=\"http://www.google.com\">hi</i>\n"
+ "<a href=\"http://google.com\"></a>\n"
+ "https://www.txttag.mee\n"
+ "ftp://www.example.com\n"
+ "ftps://www.example.com";
final String subst = "<a href=\"$1$2://$3\">$3</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}