const regex = /(?<!\d)([.,!?])(?![.,!?\d])|\s{2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)([.,!?])(?![.,!?\\d])|\\s{2,}', 'g')
const str = `Hello my friend.There should be a space after sentence periods and commas, but that should not apply to 40.381,32 numbers.`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);