$re = '/(?<!\d)([.,!?])(?![.,!?\d])|\s{2,}/';
$str = 'Hello my friend.There should be a space after sentence periods and commas, but that should not apply to 40.381,32 numbers.';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;