import Foundation
let pattern = #"(?<!\d)([.,!?])(?![.,!?\d])|\s{2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hello my friend.There should be a space after sentence periods and commas, but that should not apply to 40.381,32 numbers."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)