use strict;
my $str = 'Hello my friend.There should be a space after sentence periods and commas, but that should not apply to 40.381,32 numbers.';
my $regex = qr/(?<!\d)([.,!?])(?![.,!?\d])|\s{2,}/p;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";