# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\d)([.,!?])(?![.,!?\d])|\s{2,}"
test_str = "Hello my friend.There should be a space after sentence periods and commas, but that should not apply to 40.381,32 numbers."
subst = "$1 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.