using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+:\s*(.*?)(?=$|]|\s*\w+:(?:\w|\s))";
string input = @"caller message: Class::method1()
caller message1: Class::method2() message2: Class1::method1(Class2::method2())
caller message: Class1::method1(Class2::method2())
caller message1: Class1::method1(Class2::method2()) message2: Class3::method3(Class4::message4())
Class1::method1(Class2::method2()) message2: Class3::method3(Class4::method4())
[Analytics reportEvent: GENERAL_EVENT usingID: getCurrentID() withParameter: Number::numberWithFloat(Number::defaultNumber() + 1)]
[Sequence actions: DelayTime::create(1.0), CallFunc::create(this, selector(explodeCells)), NULL]
[layer runAction: Sequence::actions(actionScale, NULL)]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}