use strict;
my $str = 'caller message: Class::method1()
caller message1: Class::method2() message2: Class1::method1(Class2::method2())
caller message: Class1::method1(Class2::method2())
caller message1: Class1::method1(Class2::method2()) message2: Class3::method3(Class4::message4())
Class1::method1(Class2::method2()) message2: Class3::method3(Class4::method4())
[Analytics reportEvent: GENERAL_EVENT usingID: getCurrentID() withParameter: Number::numberWithFloat(Number::defaultNumber() + 1)]
[Sequence actions: DelayTime::create(1.0), CallFunc::create(this, selector(explodeCells)), NULL]
[layer runAction: Sequence::actions(actionScale, NULL)]';
my $regex = qr/\w+:\s*(.*?)(?=$|]|\s*\w+:(?:\w|\s))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}