# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+:\s*(.*?)(?=$|]|\s*\w+:(?:\w|\s))"
test_str = ("caller message: Class::method1()\n"
"caller message1: Class::method2() message2: Class1::method1(Class2::method2())\n"
"caller message: Class1::method1(Class2::method2())\n"
"caller message1: Class1::method1(Class2::method2()) message2: Class3::method3(Class4::message4())\n"
"Class1::method1(Class2::method2()) message2: Class3::method3(Class4::method4())\n"
"[Analytics reportEvent: GENERAL_EVENT usingID: getCurrentID() withParameter: Number::numberWithFloat(Number::defaultNumber() + 1)]\n"
"[Sequence actions: DelayTime::create(1.0), CallFunc::create(this, selector(explodeCells)), NULL]\n"
"[layer runAction: Sequence::actions(actionScale, NULL)]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.