$re = '/\w+:\s*(.*?)(?=$|]|\s*\w+:(?:\w|\s))/m';
$str = 'caller message: Class::method1()
caller message1: Class::method2() message2: Class1::method1(Class2::method2())
caller message: Class1::method1(Class2::method2())
caller message1: Class1::method1(Class2::method2()) message2: Class3::method3(Class4::message4())
Class1::method1(Class2::method2()) message2: Class3::method3(Class4::method4())
[Analytics reportEvent: GENERAL_EVENT usingID: getCurrentID() withParameter: Number::numberWithFloat(Number::defaultNumber() + 1)]
[Sequence actions: DelayTime::create(1.0), CallFunc::create(this, selector(explodeCells)), NULL]
[layer runAction: Sequence::actions(actionScale, NULL)]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);