import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+:\\s*(.*?)(?=$|]|\\s*\\w+:(?:\\w|\\s))";
final String string = "caller message: Class::method1()\n"
+ "caller message1: Class::method2() message2: Class1::method1(Class2::method2())\n"
+ "caller message: Class1::method1(Class2::method2())\n"
+ "caller message1: Class1::method1(Class2::method2()) message2: Class3::method3(Class4::message4())\n"
+ "Class1::method1(Class2::method2()) message2: Class3::method3(Class4::method4())\n"
+ "[Analytics reportEvent: GENERAL_EVENT usingID: getCurrentID() withParameter: Number::numberWithFloat(Number::defaultNumber() + 1)]\n"
+ "[Sequence actions: DelayTime::create(1.0), CallFunc::create(this, selector(explodeCells)), NULL]\n"
+ "[layer runAction: Sequence::actions(actionScale, NULL)]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}