const regex = /widget\.method[\s]*\([\s]*[\'\"]([\w]*)[\'\"]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('widget\\.method[\\s]*\\([\\s]*[\\\'\\"]([\\w]*)[\\\'\\"]', 'g')
const str = `widget.method("submit1", function() {
});
widget.method('submit2', function() {
});
assdfasdfadfasdcsv@p[qw:;lmdc kasdmcslkndxkv hbq1097736ty98ue9dewsuydfg8eaf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}