$re = '/widget\.method[\s]*\([\s]*[\'\"]([\w]*)[\'\"]/';
$str = 'widget.method("submit1", function() {
});
widget.method(\'submit2\', function() {
});
assdfasdfadfasdcsv@p[qw:;lmdc kasdmcslkndxkv hbq1097736ty98ue9dewsuydfg8eaf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);