re = /widget\.method[\s]*\([\s]*[\'\"]([\w]*)[\'\"]/
str = 'widget.method("submit1", function() {
});
widget.method(\'submit2\', function() {
});
assdfasdfadfasdcsv@p[qw:;lmdc kasdmcslkndxkv hbq1097736ty98ue9dewsuydfg8eaf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end