import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s.*";
final String string = "Cadillac 6 juin 1976 Rue de Cadillac Antoine Laumet, sieur de Cadillac et explorateur français\n"
+ "Langelier 6 juin 1976 Boulevard Langelier Sir François Charles Stanislas Langelier, maire de Québec et lieutenant-gouverneur de la province de Québec\n"
+ "Radisson 6 juin 1976 Rue Radisson Pierre-Esprit Radisson, explorateur français\n"
+ "Honoré-Beaugrand 6 juin 1976 Rue Honoré-Beaugrand Honoré Beaugrand, auteur et maire de Montréal\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}