const regex = /(\w+)\s.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\s.*', 'g')
const str = `Cadillac 6 juin 1976 Rue de Cadillac Antoine Laumet, sieur de Cadillac et explorateur français
Langelier 6 juin 1976 Boulevard Langelier Sir François Charles Stanislas Langelier, maire de Québec et lieutenant-gouverneur de la province de Québec
Radisson 6 juin 1976 Rue Radisson Pierre-Esprit Radisson, explorateur français
Honoré-Beaugrand 6 juin 1976 Rue Honoré-Beaugrand Honoré Beaugrand, auteur et maire de Montréal
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);