import Foundation
let pattern = #"(\w+)\s.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Cadillac 6 juin 1976 Rue de Cadillac Antoine Laumet, sieur de Cadillac et explorateur français
Langelier 6 juin 1976 Boulevard Langelier Sir François Charles Stanislas Langelier, maire de Québec et lieutenant-gouverneur de la province de Québec
Radisson 6 juin 1976 Rue Radisson Pierre-Esprit Radisson, explorateur français
Honoré-Beaugrand 6 juin 1976 Rue Honoré-Beaugrand Honoré Beaugrand, auteur et maire de Montréal
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)