// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+)\s.*").unwrap();
let string = "Cadillac 6 juin 1976 Rue de Cadillac Antoine Laumet, sieur de Cadillac et explorateur français
Langelier 6 juin 1976 Boulevard Langelier Sir François Charles Stanislas Langelier, maire de Québec et lieutenant-gouverneur de la province de Québec
Radisson 6 juin 1976 Rue Radisson Pierre-Esprit Radisson, explorateur français
Honoré-Beaugrand 6 juin 1976 Rue Honoré-Beaugrand Honoré Beaugrand, auteur et maire de Montréal
";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}