use strict;
my $str = 'Cadillac 6 juin 1976 Rue de Cadillac Antoine Laumet, sieur de Cadillac et explorateur français
Langelier 6 juin 1976 Boulevard Langelier Sir François Charles Stanislas Langelier, maire de Québec et lieutenant-gouverneur de la province de Québec
Radisson 6 juin 1976 Rue Radisson Pierre-Esprit Radisson, explorateur français
Honoré-Beaugrand 6 juin 1976 Rue Honoré-Beaugrand Honoré Beaugrand, auteur et maire de Montréal
';
my $regex = qr/(\w+)\s.*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";