#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?:\/\/)?([a-zA-z0-9\-]+)(\.[a-zA-z0-9\-]+)+:?[1-9]?[0-9]*\/.*$"
Local $sString = "http://vubpaperboy.com/asdjn?rtrwt=asdahb" & @CRLF & _
"https://vubpaperboy.com/asdjn?rtrwt=asdahb" & @CRLF & _
"vubpaperboy.com/asdjn?rtrwt=asdahb" & @CRLF & _
"http://asdafyg.vubpaperboy.com/asdjn?rtrwt=asdahb" & @CRLF & _
"https://38trbfgbg54.vubpaperboy.com/asdjn?rtrwt=asdahb" & @CRLF & _
"qw478t487.vubpaperboy.com/asdjn?rtrwt=asdahb" & @CRLF & _
"https://subdomain.localhost:8000/" & @CRLF & _
"subdomain.localhost:8000/" & @CRLF & _
"http://u7otqmedxrm4c.eris-sascha:13081/portal/pb/index.xhtml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")