const regex = /^(https?:\/\/)?([a-zA-z0-9\-]+)(\.[a-zA-z0-9\-]+)+:?[1-9]?[0-9]*\/.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/)?([a-zA-z0-9\\-]+)(\\.[a-zA-z0-9\\-]+)+:?[1-9]?[0-9]*\\\/.*$', 'gm')
const str = `http://vubpaperboy.com/asdjn?rtrwt=asdahb
https://vubpaperboy.com/asdjn?rtrwt=asdahb
vubpaperboy.com/asdjn?rtrwt=asdahb
http://asdafyg.vubpaperboy.com/asdjn?rtrwt=asdahb
https://38trbfgbg54.vubpaperboy.com/asdjn?rtrwt=asdahb
qw478t487.vubpaperboy.com/asdjn?rtrwt=asdahb
https://subdomain.localhost:8000/
subdomain.localhost:8000/
http://u7otqmedxrm4c.eris-sascha:13081/portal/pb/index.xhtml`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}