// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(https?:\/\/)?([a-zA-z0-9\-]+)(\.[a-zA-z0-9\-]+)+:?[1-9]?[0-9]*\/.*$").unwrap();
let string = "http://vubpaperboy.com/asdjn?rtrwt=asdahb
https://vubpaperboy.com/asdjn?rtrwt=asdahb
vubpaperboy.com/asdjn?rtrwt=asdahb
http://asdafyg.vubpaperboy.com/asdjn?rtrwt=asdahb
https://38trbfgbg54.vubpaperboy.com/asdjn?rtrwt=asdahb
qw478t487.vubpaperboy.com/asdjn?rtrwt=asdahb
https://subdomain.localhost:8000/
subdomain.localhost:8000/
http://u7otqmedxrm4c.eris-sascha:13081/portal/pb/index.xhtml";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}