re = /^(https?:\/\/)?([a-zA-z0-9\-]+)(\.[a-zA-z0-9\-]+)+:?[1-9]?[0-9]*\/.*$/m
str = 'http://vubpaperboy.com/asdjn?rtrwt=asdahb
https://vubpaperboy.com/asdjn?rtrwt=asdahb
vubpaperboy.com/asdjn?rtrwt=asdahb
http://asdafyg.vubpaperboy.com/asdjn?rtrwt=asdahb
https://38trbfgbg54.vubpaperboy.com/asdjn?rtrwt=asdahb
qw478t487.vubpaperboy.com/asdjn?rtrwt=asdahb
https://subdomain.localhost:8000/
subdomain.localhost:8000/
http://u7otqmedxrm4c.eris-sascha:13081/portal/pb/index.xhtml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end