import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/)?([a-zA-z0-9\\-]+)(\\.[a-zA-z0-9\\-]+)+:?[1-9]?[0-9]*\\/.*$";
final String string = "http://vubpaperboy.com/asdjn?rtrwt=asdahb\n"
+ "https://vubpaperboy.com/asdjn?rtrwt=asdahb\n"
+ "vubpaperboy.com/asdjn?rtrwt=asdahb\n"
+ "http://asdafyg.vubpaperboy.com/asdjn?rtrwt=asdahb\n"
+ "https://38trbfgbg54.vubpaperboy.com/asdjn?rtrwt=asdahb\n"
+ "qw478t487.vubpaperboy.com/asdjn?rtrwt=asdahb\n"
+ "https://subdomain.localhost:8000/\n"
+ "subdomain.localhost:8000/\n"
+ "http://u7otqmedxrm4c.eris-sascha:13081/portal/pb/index.xhtml";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}