# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(https?:\/\/)?([a-zA-z0-9\-]+)(\.[a-zA-z0-9\-]+)+:?[1-9]?[0-9]*\/.*$"
test_str = ("http://vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"https://vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"http://asdafyg.vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"https://38trbfgbg54.vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"qw478t487.vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"https://subdomain.localhost:8000/\n"
"subdomain.localhost:8000/\n"
"http://u7otqmedxrm4c.eris-sascha:13081/portal/pb/index.xhtml")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.