#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:[+-]|\+\/\-)?\d+(?:\.\d+)?[kbmt]?$"
Local $sString = "9" & @CRLF & _
"90" & @CRLF & _
"90.00" & @CRLF & _
"90.99" & @CRLF & _
"90k" & @CRLF & _
"90.00k" & @CRLF & _
"90.99k" & @CRLF & _
"" & @CRLF & _
"+9" & @CRLF & _
"-90" & @CRLF & _
"+90.00" & @CRLF & _
"-90.99" & @CRLF & _
"+90k" & @CRLF & _
"-90.00k" & @CRLF & _
"+90.99k" & @CRLF & _
"" & @CRLF & _
"+/-9" & @CRLF & _
"+/-90" & @CRLF & _
"+/-90.00" & @CRLF & _
"+/-90.99" & @CRLF & _
"+/-90k" & @CRLF & _
"+/-90.00k" & @CRLF & _
"+/-90.99k" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")