$re = '/^(?:[+-]|\+\/\-)?\d+(?:\.\d+)?[kbmt]?$/mi';
$str = '9
90
90.00
90.99
90k
90.00k
90.99k
+9
-90
+90.00
-90.99
+90k
-90.00k
+90.99k
+/-9
+/-90
+/-90.00
+/-90.99
+/-90k
+/-90.00k
+/-90.99k
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);