package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:[+-]|\+\/\-)?\d+(?:\.\d+)?[kbmt]?$`)
var str = `9
90
90.00
90.99
90k
90.00k
90.99k
+9
-90
+90.00
-90.99
+90k
-90.00k
+90.99k
+/-9
+/-90
+/-90.00
+/-90.99
+/-90k
+/-90.00k
+/-90.99k
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}