using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[+-]|\+\/\-)?\d+(?:\.\d+)?[kbmt]?$";
string input = @"9
90
90.00
90.99
90k
90.00k
90.99k
+9
-90
+90.00
-90.99
+90k
-90.00k
+90.99k
+/-9
+/-90
+/-90.00
+/-90.99
+/-90k
+/-90.00k
+/-90.99k
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}