const regex = /^(?:[+-]|\+\/\-)?\d+(?:\.\d+)?[kbmt]?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[+-]|\\+\\\/\\-)?\\d+(?:\\.\\d+)?[kbmt]?$', 'gmi')
const str = `9
90
90.00
90.99
90k
90.00k
90.99k
+9
-90
+90.00
-90.99
+90k
-90.00k
+90.99k
+/-9
+/-90
+/-90.00
+/-90.99
+/-90k
+/-90.00k
+/-90.99k
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}