// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:[+-]|\+\/\-)?\d+(?:\.\d+)?[kbmt]?$").unwrap();
let string = "9
90
90.00
90.99
90k
90.00k
90.99k
+9
-90
+90.00
-90.99
+90k
-90.00k
+90.99k
+/-9
+/-90
+/-90.00
+/-90.99
+/-90k
+/-90.00k
+/-90.99k
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}