#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\#\s(\d+)\s\"(.*)\"\s(\d+)\sBOT\s(\d+)\s(.*)\s(\d+)\s(\d+)\s(.*)$"
Local $sString = "# 8 "Name" 3882 BOT 21 23:56 31 0 127.0.0.1:20070"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")