$re = '/^\#\s(\d+)\s\"(.*)\"\s(\d+)\sBOT\s(\d+)\s(.*)\s(\d+)\s(\d+)\s(.*)$/';
$str = '# 8 "Name" 3882 BOT 21 23:56 31 0 127.0.0.1:20070';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);