const regex = /^\#\s(\d+)\s\"(.*)\"\s(\d+)\sBOT\s(\d+)\s(.*)\s(\d+)\s(\d+)\s(.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\#\\s(\\d+)\\s\\"(.*)\\"\\s(\\d+)\\sBOT\\s(\\d+)\\s(.*)\\s(\\d+)\\s(\\d+)\\s(.*)$', '')
const str = `# 8 "Name" 3882 BOT 21 23:56 31 0 127.0.0.1:20070`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}