re = /^\#\s(\d+)\s\"(.*)\"\s(\d+)\sBOT\s(\d+)\s(.*)\s(\d+)\s(\d+)\s(.*)$/
str = '# 8 "Name" 3882 BOT 21 23:56 31 0 127.0.0.1:20070'
# Print the match result
str.match(re) do |match|
puts match.to_s
end