using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\#\s(\d+)\s\""(.*)\""\s(\d+)\sBOT\s(\d+)\s(.*)\s(\d+)\s(\d+)\s(.*)$";
string input = @"# 8 ""Name"" 3882 BOT 21 23:56 31 0 127.0.0.1:20070";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}