import Foundation
let pattern = ##"^\#\s(\d+)\s\"(.*)\"\s(\d+)\sBOT\s(\d+)\s(.*)\s(\d+)\s(\d+)\s(.*)$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"# 8 "Name" 3882 BOT 21 23:56 31 0 127.0.0.1:20070"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}