using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(The law\s+\w+\s\P{Lu}*)(\p{Lu}.*?)(?=The law|$)";
string input = @"The law of Huxley Something interesting. Some other interesting thing. The law of Dallas This thing is boring.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}