$re = '/(The law\s+\w+\s\P{Lu}*)(\p{Lu}.*?)(?=The law|$)/m';
$str = 'The law of Huxley Something interesting. Some other interesting thing. The law of Dallas This thing is boring.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);