re = /(The law\s+\w+\s\P{Lu}*)(\p{Lu}.*?)(?=The law|$)/m
str = 'The law of Huxley Something interesting. Some other interesting thing. The law of Dallas This thing is boring.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end