import re
regex = re.compile(r"(The law\s+\w+\s\P{Lu}*)(\p{Lu}.*?)(?=The law|$)", flags=re.MULTILINE)
test_str = "The law of Huxley Something interesting. Some other interesting thing. The law of Dallas This thing is boring."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")