#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*?)\n(.*?)"
Local $sString = "02.04.2024 02.04.2024 280 "ADDEBITO SEPA DD PER FATTURA A VOSTRO CARICO Incasso 2023-03-24" & @CRLF & _
"17 53 26.259 SDD da IT38ZZZ0000001168010070 KNOT SRL mandato nr." & @CRLF & _
"BJWRS001212620072" -871,18" & @CRLF & _
"02.04.2024 29.03.2024 43 "PAGAMENTO VISA Contactless del 29/03/2024 CARTA *8642 DI EUR 15,12 2L" & @CRLF & _
"AOSTA" -15,12" & @CRLF & _
"03.04.2024 03.04.2024 48 "BONIFICO A VOSTRO FAVORE BONIFICO SEPA DA LA KIUVA SOCIETA" & @CRLF & _
"COOPERATIVA PER fattura COMM 0,00 SPESE 0,00 TRN 1001240942034482" 1.098,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")